[Ohrrpgce] SVN: james/8911 Add mouse.hero_move node to general.reld

Ralph Versteegen teeemcee at gmail.com
Thu Jun 29 18:50:44 PDT 2017


On 30 June 2017 at 13:45, Ralph Versteegen <teeemcee at gmail.com> wrote:

>
>
> On 30 June 2017 at 08:59, <subversion at hamsterrepublic.com> wrote:
>
>> james
>> 2017-06-29 13:59:27 -0700 (Thu, 29 Jun 2017)
>> 187
>> Add mouse.hero_move node to general.reld
>> It can be toggled on and off in a hidden "Mouse Options" menu in the
>> "spam" menu,
>> or from the F8 debug menu.
>> It does not actually DO anything yet
>> ---
>> U   wip/common.bi
>> U   wip/common.rbas
>> U   wip/custom.bas
>> U   wip/customsubs.bi
>> U   wip/customsubs.rbas
>> U   wip/game.bas
>> _______________________________________________
>> Ohrrpgce mailing list
>> ohrrpgce at lists.motherhamster.org
>> http://lists.motherhamster.org/listinfo.cgi/ohrrpgce-motherhamster.org
>
>
> IIF(GetChildNodeInt(mousenode, "move_hero", 0) <> 0, YES, NO)
> is equivalent to
> mousenode."move_hero".bool
> And for that matter, the IIF does nothing, because relational operators
> return 0 or -1
>

Oh, actually the entire function could be simplified to two lines:
 DIM gen_root as NodePtr = get_general_reld()
 RETURN gen_root."mouse"."move_hero".bool
At some point I should change RB to allow simplifying it down to one line.
set_mouse_hero_move_enabled can also be simplified, so I'll do that now
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.motherhamster.org/pipermail/ohrrpgce-motherhamster.org/attachments/20170630/5b8cc7eb/attachment.htm>


More information about the Ohrrpgce mailing list